wired raven - new vision

文字通りの日記。主に思ったことやガジェットについて

ローカルで動かしていたWikiを変更した

ローカルにメモ帳として動かしていたXAMPP+Pukiwiki 1.4.7。

XAMPPのアップデートでPHPが5.3から5.4に変わり、PHP 5.4非対応のUnicodePukiwiki 1.4.7が動かなくなってしまった。非公式のパッチや問題の箇所の修正で対応できるらしい。

あれこれ触るのも大変だったので、XAMPP+Pukiwiki構成をやめてPukiWiki Advance for Winginixに変更。

http://sourceforge.jp/projects/pukiwiki-adv/

Pukiwikiを改良したPukiWiki Adv.とローカルで動かすのに必要なソフトウェア一式がパッケージされたもの。展開すればすぐに使えると非常に手軽。

公式のFAQに従ってデバッグモードの解除とパスワードを設定して動作を軽く確認。

その後、PukiwikiのコンテンツをPukiWiki Adv.にコピーして作業完了。

存外、あっさりと移行できた。